Modified AMD/ATI driver to allow higher refresh rates
Join Today
+ Reply to Thread
Page 1 of 31 1 2 3 11 ... LastLast
Results 1 to 10 of 307
  1. #1
    ToastyX - Technical Expert
    Join Date
    May 2012
    Thanked 180 Times in 45 Posts

    Modified AMD/ATI driver to allow higher refresh rates

    Use AMD/ATI Pixel Clock Patcher to patch the driver, then use Custom Resolution Utility to add higher refresh rates.
    Last edited by ToastyX; 09-10-2012 at 07:06 AM.

  2. The Following 17 Users Say Thank You to ToastyX For This Useful Post:

    Bojamijams (08-25-2012), Catrik (07-01-2012), cirthix (08-02-2012), Dixon Butz (06-18-2012), DJManiac (09-16-2012), dwolvin (12-30-2012), evangelionstar (07-01-2012), Excidium (07-08-2012), Gar (06-10-2013), gloat (08-19-2012), jackstar7 (12-11-2012), Munchkinpuncher (08-03-2012), RAMPAGEsqgl (06-29-2012), reinhardrudi (08-14-2012), sammysamsam (07-25-2012), tweakpower (10-15-2012), voxml (07-01-2012)

  3. #2
    I'm going to do a backflip cartwheel if this works... and I can't do either.

  4. #3
    Very nice!

  5. #4
    You could use compress.exe (from microsoft) to turn the .sys into a .sy_ file and replace the atikmdag.sy_ in the driver installation folder (the one that defaults to c/amd/support/...) when installing.

    I just did this method and will try installing when home.

    edit: this doesnt work, drivers fail to install.

    toasty's method works just fine though
    You can skip the hassle of setting overrides if you flash the edid to a 120hz one.
    Last edited by cirthix; 06-04-2012 at 10:15 PM.

  6. #5
    Careful, the .sys files might bring the wrath of AMD's copyright monkeys on you... Try using xdelta to make the patch files for the .sys; then it should be all OK

  7. #6
    Senior Member
    Join Date
    May 2012
    Thanked 91 Times in 84 Posts
    I have a GTX580 in my main rig but I gotta say ... fantastic work on this ToastyX!
    Now where is that 'bow down' smiley

  8. #7
    I would just like to add that if you're trying to do video playback with media player classic (I was using homecinema) and you're getting a green screen, you don't need to switch your renderer to alleviate the problem. You simply need to go to the "Internal Filters" section of the options for MPC and uncheck DXVA. You can then leave the renderer on EVR or whatever it was set to before.

  9. #8
    you mean there is hope for me when i get a 7950 to do over 100hz?? you are a God if this works.

  10. #9
    Quote Originally Posted by sammysamsam View Post
    you mean there is hope for me when i get a 7950 to do over 100hz?? you are a God if this works.
    More than a hope; we have yet to see a report of a radeon 7-series where this didn't work, although the sample size is still quite small. I've run mine as high as 120Hz on my 7970 with no problems except for the green-screen issues already detailed.

  11. #10
    Join Date
    Apr 2012
    Perth, Australia
    Thanked 0 Times in 0 Posts
    I'll try this tonight!

    Can you also post your CRU stats for 110 or 120Hz please =)


Visitors found this page by searching for showthread

amd custom refresh rate


amd modified drivers

ati modified drivers

ati refresh fix windows 7

atikmdag.sys not digitally signed

custom refresh rate ati

custom refresh rate amd

amd refresh rate fix

ati custom refresh rate

ati doesnt allow

modified amd drivers

ati 120hz driverscvt ati windowsNGO.cercustom refresh rate windows 7atidriverpatchermodified ati driversati refresh rate fix windows 7modified amd ati driver higher refresh ratesamd catalyst modified drivershttp:120hz.netshowthread.php270-Modified-AMD-ATI-driver-to-allow-higher-refresh-rates&p=10018#post10018amd refresh ratehttp:120hz.netshowthread.php270-Modified-AMD-ATI-driver-to-allow-higher-refresh-rates

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts